facebook1 youtube1 twitter1 instagram linkedin1 pinterest1

NOTICE:  If you are not a free registered member of the site, you will not see the photos in the forum, and you won't be able to access our premium member content. Please consider joining our community! REGISTER AND MAKE THIS BOX DISAPPEAR!

Question No lights or horn with out running engine

  • TIGER500
  • TIGER500's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 15
  • Likes received: 1
All lights and horn work with engine running .battery fully charged and checked .but no lights or horn without running engine .get a very quiet horn as if battery is flat .but ifs fully charged and properly connected. 
27 Nov 2021 03:39 #1

Please Log in or Create an account to join the conversation.

  • Posts: 3525
  • Likes received: 1384

Replied by Gr8uncleal on topic No lights or horn with out running engine

I assume that this is your DT3?

Headlight and clock illumination lights only work with the engine running and the ignition key in the second click round. Other lights, indicators and horn should work off the battery, whether or not the engine is running.

The points inside the horn might need cleaning, or there might be an adjusting screw on the horn itself that you can try adjusting and see if there is any improvement.
27 Nov 2021 05:05 #2

Please Log in or Create an account to join the conversation.

  • TIGER500
  • TIGER500's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 15
  • Likes received: 1

Replied by TIGER500 on topic No lights or horn with out running engine

Hi  Ron
nothing works as it should with engine off .indicators light up just about but won't flash. Horn is a half hearted beep.back light is just about visible.but after engine has been stopped for a few minutes nothing works .just like a flat battery. But battery  is new and fully charged.as for front light the new led bulb works very well.
Regards keith
27 Nov 2021 05:15 #3

Please Log in or Create an account to join the conversation.

  • Posts: 3525
  • Likes received: 1384

Replied by Gr8uncleal on topic No lights or horn with out running engine

Has the rectifier been tested as good? You'll need a tester that can check resistance. New universal 6v rectifiers are a tenner or less from Rex's.

Charge the battery up and then connect it direct to the tail light and horn and see if there is a noticeable improvement.

Glad the led light works. 

This image is hidden for guests.
Please log in or register to see it.

The following user(s) Liked this Post: MarkT
Last edit: 27 Nov 2021 06:11 by Gr8uncleal.
27 Nov 2021 05:26 #4

Please Log in or Create an account to join the conversation.

  • Posts: 51
  • Likes received: 36

Replied by alnarv on topic No lights or horn with out running engine

Get out your voltmeter and test running and stopped. It could be either a bad battery or your rectifier diode shorted. If the diode is shorted it could pull down the battery voltage when the engine is stopped. This could damage your charging circuit, so disconnect the lead from the magneto charging coil and see if the tail light and horn work.
Alnarv
The following user(s) Liked this Post: MarkT
27 Nov 2021 05:34 #5

Please Log in or Create an account to join the conversation.

  • Posts: 7028
  • Likes received: 2627

Replied by RT325 on topic No lights or horn with out running engine

Bad earth for the main loom. Have you changed the plug coil as think it all earths there to one mount.
27 Nov 2021 17:47 #6

Please Log in or Create an account to join the conversation.

Moderators: yamadminEnduronutMakotosunDEETVinnieDevinJames Hart